Logocontrol aus Raspi installieren

Willkommen Foren LogoControl Logocontrol aus Raspi installieren

12 Beiträge anzeigen - 1 bis 12 (von insgesamt 12)
  • Autor
    Beiträge
  • #1386
    reinhard
    Teilnehmer

    Hallo.
    Habe versucht Logocontrol auf einem Raspi 2 lt. Anleitung zu installieren.
    Leider scheint es nicht zu funktionieren.

    das start.sh script wird scheinbar normal ausgeführt.
    Aber wenn ich im Browser logocontrol:8088 eingebe kommt nichts.
    Wie kommt es, dass der Hostname „logocontrol“ mit der richtigen IP Adresse aufgelöst wird?
    (Im lokalen Netz)

    Bitte um Hilfe.
    Danke & LG
    Reinhard

    #1399
    reinhard
    Teilnehmer

    Hallo nochmal.
    Wie es scheint macht mein Router (TP Link 3420) keine Namensauflösung im internen Netz (kein DNS Server)
    Es werden lediglich die externen DNS Server aus dem WAN verwendet.

    Aber ich kann auch per ip Adresse nicht auf das Service der logocontrol zugreifen. (weder port 80 noch 8080 noch 8088)
    Gibts noch Tipps zu Fehlerbehebung?
    Danke.
    LG
    Reinhard

    #1400
    admin
    Verwalter

    Also zuerst mal dein Hostname steht in der /etc/hostname kannst ihn aber auch über das Tool „raspi-config“ unter den „Advanced…“ Einstellungen ändern.

    Die Namensauflösung sollte eigentlich dein Router machen. Vergibt dein Router per DHCP die IP-Adressen oder manuell? Wenn der Hostname deines Pi tatsächlich „logocontrol“ ist (siehtst du auf der Kommandozeile, da sollte dann pi@logocontrol stehen), dann versuch mal zuerst von dem Rechner von dem du auf den Pi zugreifen möchtest ein „ping logocontrol“ zu machen. Wenn das geht, die Weboberfläche unter „http://logocontrol:8088“ aber trotzdem nicht erreichbar ist, dann ist es zumindest kein Router/DNS-Problem.

    Wie sieht denn deine config.xml aus? Ist da der folgende Eintrag noch enthalten:
    <httpWebservice port="8088" />

    Mach mal auf der Shell deines Pi folgendes:
    wget -qO- http://localhost:8088/rest/attributes

    Kommt da was zurück oder funktioniert dann die Verbindung auch nicht?

    #1417
    reinhard
    Teilnehmer

    Mein router macht leider keine Namensauflösung.
    Im Menü dhcp clients zeigt er zwar den richtigen namen (logocontrol) zur Raspberry IP Adresse an
    aber DNS Server macht er nicht

    in welchem verzeichnis sollte diese config.xml liegen?

    wget -qO- http://localhost:8088/rest/attributes bringt keinerlei output auf der console.

    Danke für die Bemühungen!
    LG
    Reinhard

    #1441
    admin
    Verwalter

    Also wenn dein Router schon den Namen „logocontrol“ im Menü anzeigt, hast du mal ein „ping logocontrol“ von der Kommandozeile des PC, mit dem du auf den Pi zugreifst, versucht? Es müssen natürlich sowohl PC als auch Pi an diesem Router hängen (bzw. per WLAN verbunden sein). Irgendwie kann ich mir das nicht so recht vorstellen, dass dein Router keine Namensauflösung im lokalen Netz unterstützt…

    Die config.xml liegt auf dem Pi im Verzeichnis LogoControl (also /home/pi/LogoControl), aber wenn du weder weißt wo sie liegt, noch die Weboberfläche jemals funktioniert hat, wirst du sie auch kaum geändert haben können, daher fällt diese Option weg 😉 Wenn LogoControl gestartet ist (sollte nach einem reboot automatisch passieren, wenn du das init.sh Skript einmalig erfolgreich ausgeführt hast, ein manueller start per start.sh ist dann nicht nötig) und der oben genannte wget nichts zurück liefert, dann scheint der Webserver in LogoControl nicht zu laufen. Dann muss jedoch irgendein Fehler aufgetreten sein und im Log stehen. Kannst du daher bitte mal die Logs unter /tmp/LogoControl.log checken? Evlt. auch noch die nohup.out in deinem Home-Verzeichnis (/home/pi)?

    Viele Grüße,
    Tobias

    #1442
    reinhard
    Teilnehmer

    Hallo.

    Nein, ping auf logocontrol hab ich schon versucht.
    es kommt dann: Ping-Anforderung konnte Host „logocontrol“ nicht finden. Überprüfen Sie den Name
    n, und versuchen Sie es erneut.
    Und ja, hängt alles am internen Netz und am Router. Einzig ein Switch ist noch vorhanden.
    Bei den dhcp Einstellungen habe ich als dns server den router selbst (192.168.0.1) eingetragen.
    Wüsste nicht mehr was man da anders machen könnte. 🙁

    config.xml ist im genannten verzeichnis nicht vorhanden.
    die genannten log dateien sind auch nicht vorhanden.

    Ich werde einmal versuchen das ganze neu zu installieren

    #1443
    reinhard
    Teilnehmer

    Noch die Frage: Einen separaten webserver wie nginx muss man ja nicht installieren oder??

    #1444
    reinhard
    Teilnehmer

    so, hab zumindest ein Problem gelöst.
    Ich hatte das Unterverzeichnis für LogoControl (wie in Linux üblich ;-)) mit kleinbuchstaben angelegt.
    Da hat nichts geklappt.
    Nun in der rc.local gesehen, dass dort in ein Verzeichnis LogoControl verwiesen wird.
    Angepasst – und –
    siehe da, der Aufruf der Webseite über die IP Adresse klappt nun endlich.

    Das Problem mit der fehlenden Namensauflösung des Routers besteht leider weiterhin.
    Vielleicht noch eine Idee dazu?

    Danke & LG
    Reinhard

    #1446
    reinhard
    Teilnehmer

    so, habe nun vom support des router herstellers die Bestätigung, dass dieser Router keinen DNS Server
    und somit keine DNS Funktionalität für das LAN bietet.
    shit.

    LG
    Reinhard

    #1448
    admin
    Verwalter

    Okay, hätte ich echt nicht erwartet. Ich hatte bisher nur FritzBoxen und Speedports in den Händen und ging davon aus, dass ein DNS fürs lokale Netz inzwischen Standard auf allen Routern sein müsste. Bleibt dir also entweder immer per IP auf deinen Pi zuzugreifen oder manuell auf deiner Windows(?) Kiste einen Eintrag für „logocontrol“ in die Hosts Datei zu machen. Die ganz große Keule wäre einen DHCP und DNS-Server auf dem Pi laufen zu lassen und den TP-Link so zu konfigurieren, dass er dann diesen verwendet.

    #1486
    reinhard
    Teilnehmer

    Hallo.
    Fürs Erste werde ich den Raspberry mittels IP Adresse ansprechen.

    Andere Frage: Ist es möglich den Webserver Nginx parallel zu Logocontrol zu installieren?
    Der Webserver horcht ja auf Port 80.
    Sollte eigentlich klappen oder?

    Danke & LG
    Reinhard

    #1487
    admin
    Verwalter

    Ja, solange die beiden auf unterschiedlichen Ports laufen, sollte es keine Probleme geben.

    Gruß
    Tobias

12 Beiträge anzeigen - 1 bis 12 (von insgesamt 12)
  • Du musst angemeldet sein, um zu diesem Thema eine Antwort verfassen zu können.