LogoControl und "Alexa"

Willkommen Foren LogoControl LogoControl und "Alexa"

Dieses Thema enthält 26 Antworten und 11 Teilnehmer. Es wurde zuletzt aktualisiert von  koenig-Berg vor 3 Monate, 1 Woche.

Ansicht von 15 Beiträgen - 1 bis 15 (von insgesamt 27)
  • Autor
    Beiträge
  • #3617

    Schrumpfkopf
    Teilnehmer

    Hi,

    ich habe 3 Logo’s 8 230V erfolgreich mit meinem Raspberry und der Logo!Control am Laufen…
    Funktioniert alles tadellos…

    Hier schon mal ein riesen kompliment an den Entwickler und dieses Forum…

    Nun bekomm ich es aber nicht geregelt die Logo!Control von unserer „Alexa“ steuern zu lassen…

    Vlt. kann mir hier jjemand beilflich sein….

    Vielen Dank im Voraus….

    #3618

    Andycode
    Teilnehmer

    Hey

    Also es gibt 2 Möglichkeiten.
    Die erste wäre mittels Ifttt einen Web request machen.
    Allerdings ist das recht unschön weil man alexa trigger Licht zb. sagen muss, aber dafür recht einfach.

    Die andere Methode wäre so wie ich es auch gemacht habe mit openhab weil mit dem Simuliert man eine Hue Lampe und mann kann einfach sagen Alexa schalte Licht ein.

    #3619

    rubi
    Teilnehmer

    Hi Schrumpfkopf,

    ich habe Alexa jetzt auch in mein SmartHome mit Logocontrol und Co. eingebunden.
    Gleich vorweg…es ist fast zu einfach!

    Installiere auf deinem Raspi (wo vermutlich auch LogoControl läuft) die Software HA-Bridge (Google bzw. LINK unten).
    HA-Bridge kannst Du mittels WebInterface konfigurieren. Lege dort ein Device an (Alexa nimmt DIESEN NAMEN das als Schlüsselwort).
    Gib dem Device dem Typ „http-Device“ und schreibe dort dein „http-Request“ rein. Also …devises/1/methods/2
    Bei HA-Bridge kannst Du die Funktion testen!
    Falls das alles funktioniert hat, kannst Du Alexa mit „Alexa, suche Geräte“ anlernen. In der Regel erkennt Sie sofort alle in HA-Bridge eingegebene Geräte! Willkommen im Jahr 2017! 😉
    Jetzt nur noch: „Alexa, schalte WOHNZIMMER EINGROßBUCHSTABEN –> Schlüsselwörter

    Hier noch ein nützlicher Link:

    HA-Bridge Installation auf dem Raspberry Pi

    #3621

    Flix
    Teilnehmer

    Hallo, liege ich richtig das bei dieser Lösung eine HUE Bridge als Hardware vonnöten ist ?

    #3624

    Guido
    Teilnehmer

    Nein Flix, Du brauchst keine weitere Hardware. Einfach den Links folgen von rubi und es läuft.

    Bei mir läuft es super, wichtig dabei ist nur auf Version „jessie“ zu sein. Mit meiner „wheezy“ Version klappte es nicht.

    Alles andere war dank der tollen Anleitungen ein Kinderspiel.

    Vielen Dank dafür!

    #3625

    Flix
    Teilnehmer

    Hi Guido,
    Da ich kein Echo dot sondern die Google Schwester habe ich leider keine Möglichkeit mehr die ha Bridge einzubinden …
    Ich habe aber inzwischen alles über LOGOControl am laufen und verbinde alles über IFTTT und Webhook

    #3632

    Schrumpfkopf
    Teilnehmer

    Hi,

    vielen Dank rubi für die ausführliche Anleitung…

    Beim ersten versuch habe ich den Raspi komplett zerschossen… Kein booten war mehr möglich…
    Nach dem neu aufsetzen hats dann aber reibungslos geklappt….

    Danke

    #3637

    jeason
    Teilnehmer

    Hallo allerseits.
    Leute ich bin am verzweifeln. Ich hab ne Sonos one mit integrierter Alexa. Hab mittlerweile die logocontrol einwandfrei am laufen. Aber die ha-Bridge bekomme ich einfach nicht hin.
    Wie muss der Target item genau aussehen?
    Warum findet die Alexa keine Geräte von der ha-Bridge?
    Danke euch schon mal

    #3639

    jeason
    Teilnehmer

    Hallo ich nochmal.
    Ich wollte meinen Beitrag nochmal etwas bearbeiten – aber das geht leider nicht. Daher verfasse ich jetzt eine Ergänzung: Mein Raspberry Pi 3 hat aktuell eine NOOBS installiert. Das selbe habe ich auch schon mit Jessie versucht. Abgesehen davon, dass ich die Target-Item nicht zum Laufen bekomme (weil ich die HTTP-URL nicht weiß), findet meine Alexa leider kein Gerät, wenn ich sie danach suchen lasse. Ich habe die Java-Version 1.8 installiert und die aktuelle HAbridge 5.1.0! Wie schon gesagt habe ich die Alexa in einer SonosOne-Box integriert, wobei ich denke, dass das keinen Unterschied machen dürfte (oder was meint ihr?).
    Ich hätte einige Fotos zu meiner Sache:
    Version von java:
    Java-Version
    HABridge-Version:
    HABrige-Version
    Und mein Target Item – was nicht funktioniert:
    Target Item

    So gesehen sind es 2 unterschiedliche Fehler, die bei mir beschreibe.
    1. Alexa findet mein Gerät „CUBE“ nicht (alles im selben Netzwerk)
    2. Ansteuerung zur LogoControl wegen fehlender URL im Target Item
    Kann mir jemand helfen? Oder gibt es eine andere Möglichkeit, der Alexa mitzuteilen, dass Sie über LogoControl eine Aktion durchführt?
    Vielen Vielen Dank an euch.

    #3640

    Flix
    Teilnehmer

    Hi,
    Also die Index muss auf jeden Fall nicht in die URL.
    Zum testen kannst du auch erstmal auf deinem Rechner die URL aufrufen und die Funktion kontrollieren.

    #3643

    jeason
    Teilnehmer

    Also muss die URL so aussehen:
    192.168.xx.157:8088/devises/4/methods/1??

    #3644

    Schrumpfkopf
    Teilnehmer

    Bei mir sieht das so aus….

    http://192.168.xxx.xxx:8088/rest/devices/EG1/methods/1

    für DICH also

    http://192.168.xx.157:8088/rest/devices/4/methods/1

    Das „rest“ fehlt da bei Dir wohl….
    Habe ich auch durch googlen gefunden… funktioniert aber….
    Und manchmal hilft auch „http://“ voranzustellen…

    Du kannst die URL natürlich auch in einen Browser eingeben.
    Dann sollte die Schaltung ebenfalls auslösen…

    Grüße

    #3647

    jeason
    Teilnehmer

    Keiner eine Idee?

    #3648

    jeason
    Teilnehmer

    Oh, super Schrumpfkopf. Vielen Dank für die Info. Den Beitrag hätt ich jetzt fast übersehen. Der Test hat übrigens funktioniert. Jetzt bleibt bloß noch das Problem, warum meine HaBridge nicht gefunden wird. Jemand eine Idee?

    #3650

    Schrumpfkopf
    Teilnehmer

    Ich musste die Geräte über die App suchen lassen… Per Sprachbefehl wurden die bei mir auch nicht gefunden…
    Und vorher einen Neustart des Pi’s

    Viel Erfolg

Ansicht von 15 Beiträgen - 1 bis 15 (von insgesamt 27)

Du musst angemeldet sein, um auf dieses Thema antworten zu können.