Zuverlässigkeit Trigger

Willkommen Foren LogoControl Zuverlässigkeit Trigger

Verschlagwortet: 

  • Dieses Thema hat 1 Antwort und 2 Stimmen, und wurde zuletzt aktualisiert vor 1 Jahr von Keden92.
2 Beiträge anzeigen - 1 bis 2 (von insgesamt 2)
  • Autor
    Beiträge
  • #4072
    Loulli
    Teilnehmer

    Ich habe Probleme mit der Zuverlässigkeit eines Triggers. Der sollte bei jedem Impuls auf einem Eingang ausgelöst werden und ein Script aufrufen, aber da gibt es regelmässig Aussetzer. Hier die Schaltung und die LogoControl-Konfiguration.

    Schaltung Logo

    
    <device id="pluvio_trigger" name="Pluviomètre">
    	<trigger plc="Logo8_cave" address="M16">
    		<onValue value="1" method="1" />
    	</trigger>
    	<method id="1" name="call bash script" script="pluviometer.sh" />
    </device>				
    

    LogoControl läuft bei mir in der aktuellen Version auf einem Raspberry Pi 3 mit aktuellem Betriebssystem.

    Die Zählimpulse werden zunächst durch ein Off-Delay entprellt und anschließend gezählt. Gleichzeitig sollte der Trigger auf M16 auslösen und Q13 wird geschaltet an dem ein ESP angeschlossen der ebenfalls mitzählt. Logo und ESP haben immer einen synchronen Zählerstand aber das Logfile des Scripts „pluviometer.sh“ zeigt, dass es regelmäßig an Zeitpunkten nicht aufgeruffen wird, wo der ESP aber einen Impuls erhält. An der Impulsfrequenz kann es nicht liegen. Die Dauer zwischen zwei Impulsen lag bisher immer über einer Minute.

    #4074
    Keden92
    Teilnehmer

    Hallo Loulli,

    Ich fasse mal kurz zusammen: Nein, Leistungsgrenze sollte dies nicht sein, jedoch kenne ich dein programm nicht. — Zu beachten wäre hier der Grenzwert von 20-Gruppen je Logo. Siehe hierzu Antwort zu: Begrenzung „word“ Werte

    Interessant wäre hier die Aktualisierungs-Rate, die dein Pi zustande bringt. (eigentlich sollte dies mit 4mal/sekunde -> 250ms passieren.)

    Baue mal folgendes auf / ein:

    Wenn dein Impuls / Signal kommt, einen RS Setzen und über einen Netzwerk-Input rücksetzen. Dieser Rücksetzaufruf wird über deinen „pluviometer.sh“ veranlasst. – Somit sollte das „nicht-zählen“ nicht mehr vorkommen. – Zusätzlich zur Analyse, eine Zeitmessung am Ausgang des RS durchführten um zu schauen wie lange dieser Zyklus in Anspruch nimmt. Sollte in der Theorie bei <= 250ms liegen. Sollte dieser wesentlich größer sein (>0,5s), dann wäre die nächste Frage: wo hängt dein RPi CPU-Technich? Was läuft da sonst noch drauf?

    VG Keden92

2 Beiträge anzeigen - 1 bis 2 (von insgesamt 2)
  • Du musst angemeldet sein, um zu diesem Thema eine Antwort verfassen zu können.